Project

General

Profile

NFS server (and client)

Added by Igor Pashev about 11 years ago

Dyson now can serve and mount NFS shares.

To make Dyson a NFS client you need to install the "illumos-nfs-common" package,
to make a NFS server - "illumos-nfs-server" (this will pull "illumos-nfs-common").

Steps to became a NFS server:

  1. Make sure you use "unstable" suite:
    # cat /etc/apt/sources.list
    deb http://apt.osdyson.org unstable main
    
  2. Update APT cache:
    # apt-get update
  3. Make a backup boot environment:
    # beadm create nfs

    Just in case something goes wrong: installing NFS server will update your kernel. In any case you will have to reboot.
  4. Install packages:
    # apt-get install illumos-nfs-server
  5. Reboot to the same boot environment (not the one you created):
    # reboot
  6. Make sure services are running and not in maintenance state:
    # svcs -a | grep nfs                                                                                                          
    disabled       21:46:13 svc:/network/nfs/nlockmgr:default                                                                                                   
    disabled       21:46:15 svc:/network/nfs/status:default                                                                                                     
    disabled       21:46:17 svc:/network/nfs/mapid:default                                                                                                      
    disabled       21:46:18 svc:/network/nfs/client:default                                                                                                     
    disabled       21:46:19 svc:/network/nfs/cbd:default                                                                                                        
    disabled       21:46:23 svc:/network/nfs/server:default
    
    # svcadm enable -r nfs/server
    

Comments